Shotgun cycling issues

Discussion in 'Shooting - Reloading Forum' started by SPRIGS, Jan 13, 2020.

  1. SPRIGS

    SPRIGS Elite Refuge Member

    Messages:
    1,668
    Joined:
    Oct 8, 2001
    Location:
    Nebraska
    This weekend in the duck blind my Franchi Affinity 3.5 started acting up.

    I loaded the gun by locking the bolt to the rear. Drop in a shell and release the bolt so it slams home and chambers the round. I then load 2 more shells through the bottom into the magazine.

    Sometimes it would not retain the last loaded shell in the magazine. On more than 1 occasion, I could not get the last loaded shell to stay in the magazine.

    One time, I loaded as described and then sat the gun down. About 5 minutes later I hear a noise and check and sure enough, the last loaded shell was kicked out of the magazine.

    Any thoughts? My brother's SBE was doing the same thing. It was cold out, 5 below when driving to the blind.
     
  2. baltz526

    baltz526 Elite Refuge Member

    Messages:
    1,170
    Joined:
    Nov 6, 2007
    Location:
    Lapine oregon
    Take it apart, clean it with one of the pressurized gun cleaners. Blow it dry with air. Run it dry.
     
  3. SPRIGS

    SPRIGS Elite Refuge Member

    Messages:
    1,668
    Joined:
    Oct 8, 2001
    Location:
    Nebraska
    So you are thinking a little lube is causing the issue? Could be. I don't run my guns with much lube though. About a drop or 2 on a q-tip for the entire bolt, rails, etc. and then I wipe them down with a dry rag before assembly.
     
  4. JFG

    JFG Elite Refuge Member

    Messages:
    3,850
    Joined:
    Sep 9, 2002
    Location:
    Coastal NC
    ^^ Above w/Baltz. Sounds like you have a little gunk or debris behind the shell stop catch mechanism.
     
    ronaldo and renoduckman like this.
  5. SPRIGS

    SPRIGS Elite Refuge Member

    Messages:
    1,668
    Joined:
    Oct 8, 2001
    Location:
    Nebraska
    Thanks guys. I will take take it apart and give it a good cleaning before the weekend.
     
  6. baltz526

    baltz526 Elite Refuge Member

    Messages:
    1,170
    Joined:
    Nov 6, 2007
    Location:
    Lapine oregon
    Dirty lube, a seed, too much lube etc is probably the problem. Clean the magazine tube also. The shell latch can wear or get bent. But a dry gun will run better on the very cold days.
     
  7. Out of focus

    Out of focus Senior Refuge Member

    Messages:
    227
    Joined:
    Nov 22, 2018
    Location:
    It appears I am surrounded by experts.
    That's just too cold! Stay home and wait until the weather warms and the gun will work.
     
  8. Ravenanme

    Ravenanme Elite Refuge Member

    Messages:
    3,600
    Joined:
    Sep 26, 2014
    Location:
    Close to where I hunt
    Baltz has got it down , your mag tube is where attention needs focused , take the spring out and thoroughly clean the inside of the tube , check the
    follower and see if it's riding crooked on the spring and if it needs replacing ! Your Shell Latch could have debis behind it ( oil,dirt,crud) which could cause
    it to hangup , Better Yet , take some time and take the gun completely down for a good scrubbing with HOT Water , blowing it off and only appling a
    light film of oil on the rails . Take your time and do a good job , it should only take you an hour or so !
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice