Truck oil pressure real high?

Discussion in 'Boats, Blinds, & Gadgets Forum' started by Fowler267, May 26, 2021.

  1. Fowler267

    Fowler267 Elite Refuge Member

    Messages:
    11,959
    Joined:
    Mar 4, 2016

    That will be my first assumption if changing the oil does not cure the issue. Do You know if they have a history of going bad? after a quarter million miles I have no complaints if it does.
     
  2. Fowler267

    Fowler267 Elite Refuge Member

    Messages:
    11,959
    Joined:
    Mar 4, 2016

    I'm not sure? The truck does use some oil. I figure it has a bad valve seal in it as it will smoke at start up but only occasionally.
     
    WHUP ! Hen likes this.
  3. tcc

    tcc Elite Refuge Member

    Messages:
    12,263
    Joined:
    Sep 13, 2006
    Location:
    Louisiana
    No idea if it's "common", but at 250k I wouldn't be surprised. Generally a pretty cheap thing to replace though to at least rule it out
     
    Fowler267 and JP like this.
  4. stevena198301

    stevena198301 Elite Refuge Member Supporting Member

    Messages:
    23,630
    Joined:
    Jan 6, 2015
    Location:
    HSV, Alabama
    Does the gauge go back to zero when you turn it off? Silly question, I know, but those year model GMs (not just 05s) had a dash cluster issue where gauges would stick when you turned the switch off. Upon cranking, wherever it stuck became the zero point. Every gauge in my 2006 did it at some point. GM refused to recall the clusters. If it’s resetting to zero on shutdown, it’s not your issue.
     
  5. Fowler267

    Fowler267 Elite Refuge Member

    Messages:
    11,959
    Joined:
    Mar 4, 2016
    IIRC it drops back.

    I had my dash covered by warranty iirc?

    I think they also worked on the "Steering column thump" ?
     
    stevena198301 likes this.
  6. baltz526

    baltz526 Elite Refuge Member

    Messages:
    1,491
    Joined:
    Nov 6, 2007
    Location:
    Lapine oregon
    Disconnect the battery for 5 minutes to reset computer. If no change, Unplug the oil pressure sending unit, spray plug with electrical contact cleaner. If no change replace sending unit.
     
    Fowler267 likes this.
  7. stevena198301

    stevena198301 Elite Refuge Member Supporting Member

    Messages:
    23,630
    Joined:
    Jan 6, 2015
    Location:
    HSV, Alabama
    Mine was out of warranty before it first happened.
     
  8. Okie Fowler

    Okie Fowler Senior Refuge Member

    Messages:
    510
    Joined:
    Oct 1, 2008
    Location:
    Muldrow, Oklahoma
    I've seen something similar and it turned out to be a bad oil pressure relief valve in the oil pump. Do you have a spin-on style oil filter? If so, is it bulged out?
     
  9. Fowler267

    Fowler267 Elite Refuge Member

    Messages:
    11,959
    Joined:
    Mar 4, 2016
    I'll have to check that?
     
  10. captb

    captb Senior Refuge Member

    Messages:
    298
    Joined:
    Sep 12, 2008
    Location:
    NE NC
    I suspect it’s the sensor. Very common on those trucks of that vintage. Replaced mine once, but it was pegged on the dash when I sold it last year- mine was and ‘06. I have a friend with an ‘05, sort of a backup truck, that is pegged right now. Most of the 5.3’s from those years use oil too. Google the marvel mystery oil fix. Worked pretty well for me.
     
    Fowler267 likes this.

Share This Page